[ 
https://issues.apache.org/jira/browse/YARN-3177?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14318874#comment-14318874
 ] 

Chris Douglas commented on YARN-3177:
-------------------------------------

[~brahmareddy] moving code for readability is completely reasonable.

In this particular instance, {{YarnConfiguration}} is a set of fields... 
Javadoc orders them and devs will look up the symbol directly. Those two cover 
basically all the users of the class; it's almost never read. Restructuring it 
offers a low payoff, compared to maintaining the history of when and why that 
field was added to {{YarnConfiguration}}. Of course that's still available, but 
this adds another lookup for a developer, which is more common.

> Fix the order of the parameters in YarnConfiguration
> ----------------------------------------------------
>
>                 Key: YARN-3177
>                 URL: https://issues.apache.org/jira/browse/YARN-3177
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Brahma Reddy Battula
>            Assignee: Brahma Reddy Battula
>            Priority: Minor
>         Attachments: YARN-3177.patch
>
>
>  *1. keep Process principal and keytab one place..( NM and RM are not placed 
> in order)* 
> {code} 
> public static final String RM_AM_MAX_ATTEMPTS =
>     RM_PREFIX + "am.max-attempts";
>   public static final int DEFAULT_RM_AM_MAX_ATTEMPTS = 2;
>   
>   /** The keytab for the resource manager.*/
>   public static final String RM_KEYTAB = 
>     RM_PREFIX + "keytab";
>   /**The kerberos principal to be used for spnego filter for RM.*/
>   public static final String RM_WEBAPP_SPNEGO_USER_NAME_KEY =
>       RM_PREFIX + "webapp.spnego-principal";
>   
>   /**The kerberos keytab to be used for spnego filter for RM.*/
>   public static final String RM_WEBAPP_SPNEGO_KEYTAB_FILE_KEY =
>       RM_PREFIX + "webapp.spnego-keytab-file";
> {code}
>  *2.RM  webapp adress and port are not in order* 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to