[ https://issues.apache.org/jira/browse/YARN-2421?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14543775#comment-14543775 ]
Jason Lowe commented on YARN-2421: ---------------------------------- Thanks for updating the patch, Chang! It's looking much better, and all that is left now are mostly nits. The stubbed allocation should be constant like EMPTY_ALLOCATION in AbstractYarnScheduler. There's no need to construct the exact same object each time we need it. For improved readability it'd be nice to have a line between the new unit test and the test before it. The new unit test should be named a bit more specifically than just "bad allocation." Something like testAllocateAfterUnregister since that's literally what the test is doing. Could you elaborate on why the sleep(1000) is needed? In general we want to avoid any unnecessary sleeps, as our unit tests take too long as it is already. Should we be draining a dispatcher instead? > CapacityScheduler still allocates containers to an app in the FINISHING state > ----------------------------------------------------------------------------- > > Key: YARN-2421 > URL: https://issues.apache.org/jira/browse/YARN-2421 > Project: Hadoop YARN > Issue Type: Bug > Components: scheduler > Reporter: Thomas Graves > Assignee: Chang Li > Attachments: YARN-2421.4.patch, YARN-2421.5.patch, YARN-2421.6.patch, > YARN-2421.7.patch, yarn2421.patch, yarn2421.patch, yarn2421.patch > > > I saw an instance of a bad application master where it unregistered with the > RM but then continued to call into allocate. The RMAppAttempt went to the > FINISHING state, but the capacity scheduler kept allocating it containers. > We should probably have the capacity scheduler check that the application > isn't in one of the terminal states before giving it containers. -- This message was sent by Atlassian JIRA (v6.3.4#6332)