[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12907324#action_12907324
 ] 

Ivan Kelly commented on ZOOKEEPER-868:
--------------------------------------

src/java/main/org/apache/zookeeper/ClientCnxn.java:L709 (SendThread::run)
There's a lot of instanceof used with exceptions. Really you should give each 
exception it's own catch, and then put the common code in a finally clause.

src/java/main/org/apache/zookeeper/ClientCnxn.java:L920 
(SendThread::readResponse)
This method has a lot of magic numbers being used. These should be defined as 
consts somewhere and used as such.

src/java/main/org/apache/zookeeper/ClientCnxn.java:L755 (TODO is near 
SendThread::getZkState)
Theres a TODO about making SendThread an implementation of Runnable. This 
change should be fairly simple, so why not do it before submitting?



> Cleanups from ZOOKEEPER-823 patch
> ---------------------------------
>
>                 Key: ZOOKEEPER-868
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-868
>             Project: Zookeeper
>          Issue Type: Sub-task
>            Reporter: Ivan Kelly
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to