Asad Habib wrote:
Actually, it does exist as I mentioned in my original message. If it did
not exist, then <dtml-var "REQUEST.SESSION"> would yield a value of None
for it. Also, if this were the case, then simply changing the name of the
variable would not solve the problem.

I think that Andreas is pointing out an inconsistency in your original post, and you should check and make sure that the inconsistency does not actually exist in your program.

First you indicate that you set a variable called
"undergradProjectsDirected":

I declare using the following syntax:

<dtml-call "REQUEST.SESSION.set('undergradProjectsDirected', [ ])">

But then you indicate that you are using the following to add items:

I am using the following statement to append items:

<dtml-call
"(REQUEST.SESSION.get('undergraduateProjectsDirected')).append([student_n
ame, description])">

Notice that this time you are using "undergraduateProjectsDirected". Please check and then indicate whether this is true in your actual program. Obviously, if you are goign to change the name of the variable, you have to be consistent. Andreas is just indicating that perhaps you haven't been careful to ensure this.

HTH,
JZ

_______________________________________________
Zope maillist - Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to