On Thu, 28 Oct 2004 13:57:15 -0400, Ted Husted wrote:
> ... that we rename the package called "impl" as "faces".

As to the impl package:

I think what really bothers me here is that the classes implemented here are not part 
of the Shale API. As soon as I saw ImplViewHandler, I starting looking around for a 
Shale ViewHandler interface. :) Of course, it is not a Shale interface, but a Faces 
interface. So far, all of the members here extend Faces interfaces or classes.

To me, "impl" says we're implementing the interfaces for the Shale layer (rather than 
the Faces layer).

Naming this package "faces" clarifies that it contains classes that are dependant on 
the lower-level Faces API, as opposed to the higher-level Shale API.

What I would suggest is that we call the package "faces", and the member classes:

* "ShaleApplicationFilter"
* "ShaleConstants"
* "ShalePhaseListener"
* "ShaleViewHandler"

I'm thinking that in an import statement

* org.apache.shale.ViewController
* org.apache.shale.faces.ShaleApplicationFilter

would clearly say who's riding whom.

-Ted.


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to