On 05/28/2015 09:50 PM, That One Guy /sarcasm wrote:
Im really loving the mikrotik
This GUI is really nice in winbox, but i can see with all the small
subnets associated with moving toward OSPF Thats going to become tedious
very quickly.
I like the imagesteams because I deal with the firewall file and the
wan.conf and now the ospf files. Create them in a text editor and dump
them in.

What are the comparable files in MT, and whats the easiest way to move
files? I use winscp with the imagestreams.

There is no specific "file" really. One thing you can do, though, is separate these into "files" on your computer to manage each section of the config. A quick example for managing IP addresses.

Let's say you have the following config:
/ip address
add interface=ether1 address=10.10.10.10/24 comment="WAN IP"
add interface=ether2 address=10.10.11.1/24 comment="SW AP"
add interface=ether3 address=10.10.12.1/24 comment="NW AP"


Down the road, you want to add an IP to the router, you can upload a file like this:
/ip address
add interface=ether4 address=10.10.13.1/24 comment="Another AP"
/ip address export  file=MyRouterIP

After uploading this file (assuming you name it "NewIPSpace.rsc"):
/import NewIPSpace.rsc

After importing this, you will find a file called "MyRouterIP.rsc" on the file system, which you can download to your computer for backup or whatever.

Or, suppose you want to change the IP on ether2 from 10.10.11.1/24 to 10.10.15.1/24 for some reason. Your file would look like this:

/ip address
set [find comment="SW AP"] address=10.10.15.1/24 network=10.10.15.0
/ip address export  file=MyRouterIP

Just be sure that your connection to the router isn't using the 10.10.11.1 IP for either a gateway OR for the connection itself. One other approach would be if you didn't want to CHANGE the existing IPs, but wanted to simply ADD one, you could send a file like this:

/ip address
add interface=ether1 address=10.10.10.10/24 comment="WAN IP"
add interface=ether2 address=10.10.11.1/24 comment="SW AP"
add interface=ether3 address=10.10.12.1/24 comment="NW AP"
add interface=ether4 address=10.10.13.1/24 comment="New IP being Added"
/ip address export  file=MyRouterIP


When you import this one, it will simply give you an error for the first 3 lines that attempt to "add" and IP, since the IP addresses already exist, but the script should still run.





--
Butch Evans
702-537-0979
Network Support and Engineering
http://store.wispgear.net/
http://www.butchevans.com/

Reply via email to