Tidying up cz_hwmgr.c I noted a couple of things but first is

static bool cz_dpm_check_smu_features(struct pp_hwmgr *hwmgr,
unsigned long check_feature);

Which will return "true" if the smu call fails or the feature is set.

The structure

struct phm_clock_voltage_dependency_table;

Has a [1] array at the tail which is then kzalloc'ed with N-1 entries.  
Shouldn't that just be a [0] with N entries allocated for clarity?

Tom

_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx

Reply via email to