Any modern GCC should support [0] at the tail of a struct.  This came up 
because when I was reading the code I saw they allocated 7 slots (plus the size 
of the struct) but then fill 8 slots.  It's just weird [😊]


Using [0] in the struct and allocating for 8 entries makes more sense and is 
clearer to read.


Tom


________________________________
From: Christian König <deathsim...@vodafone.de>
Sent: Thursday, August 18, 2016 11:17
To: StDenis, Tom; amd-gfx list
Subject: Re: tidy'ing up cz_hwmgr.c

Has a [1] array at the tail which is then kzalloc'ed with N-1 entries.  
Shouldn't that just be a [0] with N entries allocated for clarity?
Actually the starting address of a dynamic array should be manually calculated 
instead of using [1] or [0].

We had tons of problems with that because some gcc versions get this wrong and 
the atombios code used this as well.

Alex how did we resolved such issues?

Regards,
Christian.

Am 18.08.2016 um 16:26 schrieb StDenis, Tom:

Tidying up cz_hwmgr.c I noted a couple of things but first is


static bool cz_dpm_check_smu_features(struct pp_hwmgr *hwmgr,
unsigned long check_feature);

Which will return "true" if the smu call fails or the feature is set.

The structure

struct phm_clock_voltage_dependency_table;

Has a [1] array at the tail which is then kzalloc'ed with N-1 entries.  
Shouldn't that just be a [0] with N entries allocated for clarity?

Tom




_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org<mailto:amd-gfx@lists.freedesktop.org>
https://lists.freedesktop.org/mailman/listinfo/amd-gfx


_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx

Reply via email to