This commit updates some comments to be more precise and adds another
small comment to some other parts to improve the code readability.

Signed-off-by: Rodrigo Siqueira <rodrigo.sique...@amd.com>
---
 drivers/gpu/drm/amd/display/dc/dc.h                 | 10 +++++-----
 drivers/gpu/drm/amd/display/dc/dcn20/dcn20_hubp.h   |  2 +-
 drivers/gpu/drm/amd/display/dc/dcn201/dcn201_hubp.c |  5 +++++
 3 files changed, 11 insertions(+), 6 deletions(-)

diff --git a/drivers/gpu/drm/amd/display/dc/dc.h 
b/drivers/gpu/drm/amd/display/dc/dc.h
index 188f2d401124..4e36a4f9a4a8 100644
--- a/drivers/gpu/drm/amd/display/dc/dc.h
+++ b/drivers/gpu/drm/amd/display/dc/dc.h
@@ -309,12 +309,12 @@ struct dc_dcc_setting {
        unsigned int max_compressed_blk_size;
        unsigned int max_uncompressed_blk_size;
        bool independent_64b_blks;
-       //These bitfields to be used starting with DCN
+       //These bitfields to be used starting with DCN 3.0
        struct {
-               uint32_t dcc_256_64_64 : 1;//available in ASICs before DCN (the 
worst compression case)
-               uint32_t dcc_128_128_uncontrained : 1;  //available in ASICs 
before DCN
-               uint32_t dcc_256_128_128 : 1;           //available starting 
with DCN
-               uint32_t dcc_256_256_unconstrained : 1;  //available in ASICs 
before DCN (the best compression case)
+               uint32_t dcc_256_64_64 : 1;//available in ASICs before DCN 3.0 
(the worst compression case)
+               uint32_t dcc_128_128_uncontrained : 1;  //available in ASICs 
before DCN 3.0
+               uint32_t dcc_256_128_128 : 1;           //available starting 
with DCN 3.0
+               uint32_t dcc_256_256_unconstrained : 1;  //available in ASICs 
before DCN 3.0 (the best compression case)
        } dcc_controls;
 };
 
diff --git a/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_hubp.h 
b/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_hubp.h
index efa2adf4f83d..8da3084d933f 100644
--- a/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_hubp.h
+++ b/drivers/gpu/drm/amd/display/dc/dcn20/dcn20_hubp.h
@@ -147,7 +147,7 @@
        uint32_t DCN_CUR1_TTU_CNTL1;\
        uint32_t VMID_SETTINGS_0
 
-
+/*shared with dcn3.x*/
 #define DCN21_HUBP_REG_COMMON_VARIABLE_LIST \
        DCN2_HUBP_REG_COMMON_VARIABLE_LIST; \
        uint32_t FLIP_PARAMETERS_3;\
diff --git a/drivers/gpu/drm/amd/display/dc/dcn201/dcn201_hubp.c 
b/drivers/gpu/drm/amd/display/dc/dcn201/dcn201_hubp.c
index 35dd4bac242a..cd2bfcc51276 100644
--- a/drivers/gpu/drm/amd/display/dc/dcn201/dcn201_hubp.c
+++ b/drivers/gpu/drm/amd/display/dc/dcn201/dcn201_hubp.c
@@ -77,6 +77,7 @@ static void hubp201_program_requestor(struct hubp *hubp,
                        MRQ_EXPANSION_MODE, rq_regs->mrq_expansion_mode,
                        CRQ_EXPANSION_MODE, rq_regs->crq_expansion_mode);
 
+       /* no need to program PTE */
        REG_SET_5(DCHUBP_REQ_SIZE_CONFIG, 0,
                CHUNK_SIZE, rq_regs->rq_regs_l.chunk_size,
                MIN_CHUNK_SIZE, rq_regs->rq_regs_l.min_chunk_size,
@@ -99,6 +100,10 @@ static void hubp201_setup(
                struct _vcs_dpi_display_rq_regs_st *rq_regs,
                struct _vcs_dpi_display_pipe_dest_params_st *pipe_dest)
 {
+       /*
+        * otg is locked when this func is called. Register are double buffered.
+        * disable the requestors is not needed
+        */
        hubp2_vready_at_or_After_vsync(hubp, pipe_dest);
        hubp201_program_requestor(hubp, rq_regs);
        hubp201_program_deadline(hubp, dlg_attr, ttu_attr);
-- 
2.43.0

Reply via email to