On 03/26/2011 01:51 PM, Alberto Ortega wrote:

>>>                  sc->rate_idx[b->band][b->bitrates[i].hw_value] = i;
>>>                  if (b->bitrates[i].hw_value_short)
>>> -                       
>>> sc->rate_idx[b->band][b->bitrates[i].hw_value_short] = i;
>>> +                       sc->rate_idx[b->band][b->bitrates[i].hw_value_short]
>>> +                                                                       = i;

It may be correct formally, but it makes the code less readable.  The 
overlong lines may indicate that some temporary variables could be 
introduced.  I think sc->rate_idx[b->band] could be such variable.  It 
would eliminate double dereference in the same expression.

>>> -       for (i=0; i<   AR5K_NUM_TX_QUEUES; i++)
>>> +       for (i = 0; i<   AR5K_NUM_TX_QUEUES; i++)

Did you look at your patch at all?

-- 
Regards,
Pavel Roskin
_______________________________________________
ath5k-devel mailing list
ath5k-devel@lists.ath5k.org
https://lists.ath5k.org/mailman/listinfo/ath5k-devel

Reply via email to