o bugfix
- bugfix: according to C99 6.10.3, the behaviour is undefined for
  preprocessor directive within a macro argument, reported by Al Boldi
  on linux-fsdevel ML.
- bugfix: replace the preceding single quotation by backquote,
  reported by Tomas M.

o news
- introducing a new patch for openvz, openvz_028stab039.1.patch.
- preparing to support linux-2.6.23 (unfinished)
  + new configuration CONFIG_AUFS_SPLICE_PATCH and
    CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH.
  + generate an auxiliary makefile /tmp/aufsvars.mk
  + begin supporting nfsv4, calling new VFS function vfs_path_lookup().
  + new functions for default nfs export operations.
  + support splice(2), and sendfile operation is dropped.
  + support inode operation truncate_range() and fallocate().
  + the function signature of kmem_cache_create() is changed.
  + warn about CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH and
    CONFIG_AUFS_SPLICE_PATCH at compile time.
  + the parameter of bin_attribute.{read,write}() is changed.

o misc
- new configuration CONFIG_AUFS_RR_SQUASHFS.
  + rename au_is_rr() to au_is_def_rr() and make it simple.
  + udf is not set RR by default, suggested by Tomas M.
- remove a configuration CONFIG_AUFS_ISSUBDIR_PATCH which has less
  meaning.
- refine the AUFS_BRANCH_MAX warning message at compile time.


Junjiro Okajima

----------------------------------------------------------------------

Index: Kconfig.in
- new configuration CONFIG_AUFS_RR_SQUASHFS.
- preparing to support linux-2.6.23 (unfinished)
  + new configuration CONFIG_AUFS_SPLICE_PATCH,
    CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH.

Index: local.mk
- preparing to support linux-2.6.23 (unfinished)
  + new configuration CONFIG_AUFS_SPLICE_PATCH,
    CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH and CONFIG_AUFS_RR_SQUASHFS.
  + generate an auxiliary makefile /tmp/aufsvars.mk
- remove a configuration CONFIG_AUFS_ISSUBDIR_PATCH which has less
  meaning.

Index: fs/aufs/Makefile
- preparing to support linux-2.6.23 (unfinished)
  + generate an auxiliary makefile /tmp/aufsvars.mk
- new configuration CONFIG_AUFS_RR_SQUASHFS.

Index: fs/aufs/aufs.h
- remove a configuration CONFIG_AUFS_ISSUBDIR_PATCH which has less
  meaning.

Index: fs/aufs/branch.c
- new configuration CONFIG_AUFS_RR_SQUASHFS.
  + rename au_is_rr() to au_is_def_rr() and make it simple.
  + udf is not set RR by default, reported by Tomas M.
- preparing to support linux-2.6.23 (unfinished)
  + begin supporting nfsv4.

Index: fs/aufs/branch.h
- new configuration CONFIG_AUFS_RR_SQUASHFS.
  + rename au_is_rr() to au_is_def_rr().

Index: fs/aufs/dcsub.c
- remove a configuration CONFIG_AUFS_ISSUBDIR_PATCH which has less
  meaning.

Index: fs/aufs/dentry.c
- bugfix: according to C99 6.10.3, the behaviour is undefined for
  preprocessor directive within a macro argument, reported by Al Boldi
  on linux-fsdevel ML.

Index: fs/aufs/dentry.h
Index: fs/aufs/dinfo.c
- preparing to support linux-2.6.23 (unfinished)
  + begin supporting nfsv4.

Index: fs/aufs/export.c
- preparing to support linux-2.6.23 (unfinished)
  + new functions for default nfs export operations.

Index: fs/aufs/f_op.c
- preparing to support linux-2.6.23 (unfinished)
  + support splice(2), and sendfile operation is dropped.

Index: fs/aufs/i_op.c
- preparing to support linux-2.6.23 (unfinished)
  + support inode operation truncate_range() and fallocate().

Index: fs/aufs/module.c
- preparing to support linux-2.6.23 (unfinished)
  + the function signature of kmem_cache_create() is changed.
  + warn about CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH and
    CONFIG_AUFS_SPLICE_PATCH at compile time.
- refine the AUFS_BRANCH_MAX warning message at compile time.

Index: fs/aufs/opts.c
- new configuration CONFIG_AUFS_RR_SQUASHFS.
  + rename au_is_rr() to au_is_def_rr().

Index: fs/aufs/sysaufs.c
- preparing to support linux-2.6.23 (unfinished)
  + new configuration CONFIG_AUFS_SPLICE_PATCH,
    CONFIG_AUFS_SYSFS_GET_DENTRY_PATCH and CONFIG_AUFS_RR_SQUASHFS.
  + the parameter of bin_attribute.{read,write}() is changed.
- remove a configuration CONFIG_AUFS_ISSUBDIR_PATCH which has less
  meaning.

Index: fs/aufs/vfsub.c
- preparing to support linux-2.6.23 (unfinished)
  + support splice(2).

Index: fs/aufs/vfsub.h
- preparing to support linux-2.6.23 (unfinished)
  + support splice(2).
  + begin supporting nfsv4, calling new VFS function vfs_path_lookup().

Index: sample/linux-vserver.txt
- refined simply.

Index: util/aufs.in.5
- bugfix: replace the preceding single quotation by backquote,
  reported by Tomas M.

Index: fs/aufs/cpup.c
Index: fs/aufs/debug.c
Index: fs/aufs/debug.h
Index: fs/aufs/file.c
Index: fs/aufs/hinotify.c
Index: fs/aufs/inode.h
Index: fs/aufs/misc.c
Index: fs/aufs/misc.h
Index: fs/aufs/sbinfo.c
Index: fs/aufs/super.c
Index: fs/aufs/super.h
Index: fs/aufs/xino.c
Index: include/linux/aufs_type.h
- less important changes.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/

Reply via email to