o current problems
- setting inode number which was previously assigned ("broken ino"
  msg) (testing).
- getdents(2) returns nothing. this may involve two problems. (it was
  one. testing)
- cpup_wh_file() failure. (testing)

o bugfix
- bugfix: force rewind at re-initializing vdir, reported by Michael
  Towers, Jorgen P. Tjerno and Sandino Flores Moreno.
- bugfix: copyup unlinked file.
  + bug #1, the file may or may not be opened, aufs needs to hold the
    copied-up temporary dentry, reported by Andreas Baetz.
  + bug #2, the file may be opened in multiple times.
  + stop dropping in cpup_regular().
  + revert AuDebugOn() from temporary WARN_ON().
  + move cpup_wh_file() in file.c to cpup.c as generic cpup_wh().
  + print wh_dentry in iinfo.
  + set wh_dentry in iifno.
  + call cpup_wh() when the file was removed.
- bugfix: overflow in multiply, reported by Jorgen P. Tjerno and Alexey
  Bazhin.
- bugfix: possible overflow in multiply.

o misc
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- maintain the number of 'nowait' tasks.
- testing where si_read_trylock() should be called.
- testing CONFIG_AUFS_ROBR
- ksize.patch will be unnecessary after linux-2.6.22, kzrealloc() calls
  krealloc().
- extract a part of inode.h as a new file hinode.h.
- support lockdep at removing nfs branch.
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- rename filldir_ino_t to au_filldir_ino_t.
- rename AUFS_{DEBLK,NHASH}_SIZE to AuSize_{DEBLK,NHASH}.
- refine the message string.
- move au_hinotifyq to wkq.h as au_nowait_tasks, new inline functions
  au_nwt_{init,inc,dec,flush}().
- move read/writef_t to super.h.
- rename find_sb_locked() to find_sb_lock().
- extract a part of this file as vserver.patch.
- consolidate arguments of do_diropq() as flags.
- consolidate arguments of au_wkq_run() as flags.
- testing FaunOS.


Junjiro Okajima

----------------------------------------------------------------------

Index: Kconfig.in
Index: fs/aufs/module.c
- ksize.patch will be unnecessary after linux-2.6.22.

Index: vserver.patch
- forgot to check-in last week.

Index: fs/aufs/aufs.h
- introduce a new header file hinode.h.

Index: fs/aufs/branch.c
- support lockdep at removing nfs branch.
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- testing CONFIG_AUFS_ROBR
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].

Index: fs/aufs/cpup.c
- bugfix: copyup unlinked file.
  + bug #1, the file may or may not be opened, aufs needs to hold the
    copied-up temporary dentry, reported by Andreas Baetz.
  + bug #2, the file may be opened in multiple times.
  + stop dropping in cpup_regular().
  + revert AuDebugOn() from temporary WARN_ON().
  + move cpup_wh_file() in file.c to cpup.c as generic cpup_wh().
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].

Index: fs/aufs/cpup.h
- bugfix: copyup unlinked file.
  + move cpup_wh_file() in file.c to cpup.c as generic cpup_wh().

Index: fs/aufs/debug.c
- rename AUFS_NHASH_SIZE to AuSize_NHASH.
- bugfix: copyup unlinked file.
  + print wh_dentry in iinfo.

Index: fs/aufs/dentry.c
- testing CONFIG_AUFS_ROBR
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.

Index: fs/aufs/dinfo.c
Index: fs/aufs/i_op_del.c
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].

Index: fs/aufs/dir.c
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- rename filldir_ino_t to au_filldir_ino_t.

Index: fs/aufs/dir.h
- use typedef instead of macro.
- rename AUFS_{DEBLK,NHASH}_SIZE to AuSize_{DEBLK,NHASH}.

Index: fs/aufs/export.c
- rename filldir_ino_t to au_filldir_ino_t.
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- testing CONFIG_AUFS_ROBR

Index: fs/aufs/f_op.c
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- testing CONFIG_AUFS_ROBR
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().

Index: fs/aufs/file.c
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- bugfix: copyup unlinked file.
  + move cpup_wh_file() in file.c to cpup.c as generic cpup_wh().
  + set wh_dentry in iifno.

Index: fs/aufs/hinotify.c
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- bugfix: copyup unlinked file.
  + set wh_dentry in iifno.
- bugfix: editing-miss left isolated inode unlock.
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- maintain the number of 'nowait' tasks.

Index: fs/aufs/i_op.c
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- bugfix: copyup unlinked file.
  + call cpup_wh() when the file was removed.

Index: fs/aufs/i_op_add.c
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().

Index: fs/aufs/i_op_ren.c
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- introduce AuLock_DIR flag for si_read/write_lock().

Index: fs/aufs/iinfo.c
- bugfix: copyup unlinked file.
  + set wh_dentry in iifno.
- testing where si_read_trylock() should be called.

Index: fs/aufs/inode.c
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- refine the message string.

Index: fs/aufs/inode.h
- extract a part of inode.h as a new file hinode.h.
- bugfix: copyup unlinked file.
  + set wh_dentry in iifno.
- rename i_lock/unlock() to vfsub_i_lock/unlock(), and move to vfsub.h.
- move au_hinotifyq to wkq.h as au_nowait_tasks.

Index: fs/aufs/misc.c
- ksize.patch will be unnecessary after linux-2.6.22, kzrealloc() calls
  krealloc().
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().

Index: fs/aufs/misc.h
- move read/writef_t to super.h.

Index: fs/aufs/opts.c
Index: fs/aufs/sbinfo.c
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.

Index: fs/aufs/plink.c
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().

Index: fs/aufs/super.c
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- maintain the number of 'nowait' tasks.

Index: fs/aufs/super.h
- move read/writef_t from misc.h.
- maintain the number of 'nowait' tasks.
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW], introduce
  AuLock_{FLUSH,DIR}.
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.

Index: fs/aufs/sysaufs.c
- rename find_sb_locked() to find_sb_lock().
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.
- rename AUFS_[ID]_[RW]LOCK to AuLock_[ID][RW].

Index: fs/aufs/vdir.c
- rename AUFS_{DEBLK,NHASH}_SIZE to AuSize_{DEBLK,NHASH}.
- rename filldir_ino_t to au_filldir_ino_t.
- bugfix: force rewind at re-initializing vdir, reported by Michael
  Towers, Jorgen P. Tjerno and Sandino Flores Moreno.
- bugfix: possible overflow in multiply.

Index: fs/aufs/vfsub.h
- rename i_lock/unlock() to vfsub_i_lock/unlock(), and move from inode.h.
- extract a part of this file as vserver.patch.

Index: fs/aufs/whout.c
- consolidate arguments of do_diropq() as flags.
- rename AUFS_{DEBLK,NHASH}_SIZE to AuSize_{DEBLK,NHASH}.
- rename i_lock/unlock() to vfsub_i_lock/unlock().
- si_read/write_lock() supports AuLock_FLUSH which flushes the
  remaining hinotify hanlder.

Index: fs/aufs/whout.h
- consolidate arguments of do_diropq() as flags.

Index: fs/aufs/wkq.c
- consolidate arguments of au_wkq_run() as flags.

Index: fs/aufs/wkq.h
- move au_hinotifyq to wkq.h as au_nowait_tasks, new inline functions
  au_nwt_{init,inc,dec,flush}().
- consolidate arguments of au_wkq_run() as flags.

Index: fs/aufs/xino.c
- bugfix: overflow in multiply, reported by Jorgen P. Tjerno and Alexey
  Bazhin.
- use hi_lock/unlock() for a hidden inodes, instead of i_lock/unlock().
- rename i_lock/unlock() to vfsub_i_lock/unlock().

Index: sample/diskless/Makefile
Index: sample/diskless/comount.sh
Index: sample/diskless/def.mk
Index: sample/diskless/linuxrc
Index: sample/diskless/pxe.conf
- testing FaunOS.

Index: README
Index: fs/aufs/branch.h
Index: fs/aufs/debug.h
Index: fs/aufs/dentry.h
Index: fs/aufs/file.h
Index: fs/aufs/opts.h
Index: fs/aufs/sysaufs.h
Index: include/linux/aufs_type.h
Index: util/aufs.in.5
- less important changes.

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/

Reply via email to