Hello,

On Fri, Nov 10, 2006 at 11:27:18AM -0700, David Everly wrote:
> I have been working to follow this.  It seems however that I need
> dist_TESTS, but this seems to not work so perhaps I should do this
> instead:
> 
> EXTRA_DIST = $(TESTS)

yes, that is fine.  One nit about style:

I would rather use

dist_check_SCRIPTS = $(TESTS)

Or perhaps the other way round.  Let me give a more general example;
perhaps some of the tests are compiled programs, some are built
stripts and some are distributed scripts.  Then you would have:

check_PROGRAMS = foo bar
foo_SOURCES = foo.c
bar_SOURCES = bar.c baz.c
nodist_check_SCRIPTS = this
# this is created from this.in by configure
dist_check_SCRIPTS = that another
TESTS = $(check_PROGRAMS) $(nodist_check_SCRIPTS) $(dist_check_SCRIPTS)

Have a nice day,
        Stepan Kasal


Reply via email to