> I thought that would be easier too, but it's counter-intuitive.

It's only counter intuitive if you think of it (and name it) something
like "score".  So yes, we need another name to make it less
counter-intuitive.  E.g. `completion-penalty'.  And I think it would be
good to make it clear that this is for cycling, so the name could be
`completion-cycle-penalty'.


        Stefan


!           (let ((s1 (get-text-property 0 :completion-score c1))
!                 (s2 (get-text-property 0 :completion-score c2)))
!             (cond ((and s1 s2) (< s1 s2))
!                   (s1 t)
!                   (s2 nil)

BTW, I'd rather use something like

!           (let ((s1 (get-text-property 0 :completion-score c1))
!                 (s2 (get-text-property 0 :completion-score c2)))
!             (cond ((and s1 s2) (cond ((< s1 s2) t)
!                                      ((> s1 s2) nil)
!                                      (t (< (length c1) (length c2)))))
!                   (s1 t)
!                   (s2 nil)

PS: Please Cc the patch to emacs-devel because I don't read this
bbdb-list as regularly.


------------------------------------------------------------------------------
What You Don't Know About Data Connectivity CAN Hurt You
This paper provides an overview of data connectivity, details
its effect on application quality, and explores various alternative
solutions. http://p.sf.net/sfu/progress-d2d
_______________________________________________
bbdb-info@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/bbdb-info
BBDB Home Page: http://bbdb.sourceforge.net/

Reply via email to