On Tue, Oct 28, 2003 at 01:44:58PM -0600, Dan Muey wrote:
>> If you don't care about older perls (and 5.005_03 is getting
>> kind of mouldy) then do something like
>>
>> use 5.006;
>>
>> use base qw(Exporter);
>
> And that brings up another issue:
> what is the difference between:
> our @ISA = qw(Exporter);
> and
> use base qw(Exporter);
>
> Is one more compatible with certain versions or better or worse ??
Don't forget that all these pragmatic modules have manpages:
% perldoc base
> It seems use base would be better since it handles @ISA and will do a
> better job at it than I.
I'm sure you would have done a fine job. :-)
But the "use base" approach will also require() the module, so it
can reduce the amount of boilerplate at the top of your module.
#
# this is more readable...
#
package Foo;
use base qw(Exporter Dynaloader);
#
# than this
#
package Foo;
require Exporter;
require Dynaloader;
our @ISA = qw(Exporter Dynaloader);
--
Steve
--
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]