> The compiler doesn't know which "shape" you are referring to.  The struct
> definition is in the style of C programming.  In C++ when you define a
> struct, the name of the struct is automatically type qualified.  So you now
> have a private type called "shape".
>

Actually that's not really correct.  It just doesn't know that you want it to 
use the private data member "shape" not the private type "shape".

> Because the struct itself is private, I would rename the type-qualified
> name to something else.  It doesn't matter what.  _shape, m_shape, p_shape,
> prv_shape,  whatever.  I think that will fix the problems.
>

I took an another look, and you will most likely have to do the same on the 
cursor struct.



That's how I understand the problem anyways,


A

Reply via email to