Joe Gottman wrote:
>     They are considering a language solution.  See this link:
> http://anubis.dkuug.dk/jtc1/sc22/wg21/docs/papers/2003/n1483.pdf

Wow, that is good.  I like the new syntax...

0,01$: But maybe they could add some template specifier before its
declaration; this could help typename / non-type arguments / template
templates arguments:

template <... typename A>
    void foo(A const &)
    {
    }

template <... long double A>
    void foo()
    {
    }

template <... template <typename> A>
    void foo()
    {
    }

foo<int, long, double>(1, 2, 3);
foo<1, 2, 3, 4, 5>();
foo<map, list, vector>();

0,01$: And they should rename 'the-return-type' to something else...
something like 'nameless' or 'holotype'.



Philippe



_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to