From: Michael Hohmuth <[EMAIL PROTECTED]>
Subject: Patch: new "modaddr" builtin
Date: 12 Nov 1999 14:53:56 +0100

> I have appended a patch that adds a new "modaddr" builtin command to
> GRUB.  This command specifies the load address for Multiboot modules.
> It can only be used after a Multiboot kernel has been loaded.

  I think this command is dangerous for end-users, and that's a dirty
solution. Is it better to put a header section in a module so that GRUB
can load it in the suitable address transparently? I want to call the
header "Multiboot module header", and the structure would be:

struct mb_module_header
{
  unsigned long magic;          /* the magic number */
  unsigned long flags;          /* the flags */
  unsigned long start_addr;     /* the staring address to be loaded */
  unsigned long end_addr;       /* the end address to be loaded */
};

And, GRUB would act as follows:

If GRUB can find the header in the first X bytes (X is 8192 or
something), GRUB tries to load the module in START_ADDR.

If the area is not available, GRUB emits an error or loads it in an
alternative address (depending on FLAGS).

If there is no header, GRUB loads it in an arbitrary address.

----------------------------------------------------------------------
OKUJI Yoshinori  <[EMAIL PROTECTED]>           ^o-o^
http://duff.kuicr.kyoto-u.ac.jp/~okuji (in English)     m /

Reply via email to