On Tue, Sep 29, 2026 at 10:23:13PM +0200, Patrice Dumas wrote:
> On Tue, Sep 29, 2026 at 08:09:37PM +0100, Gavin Smith wrote:
> > Could a keyword variable be a better idea than a Boolean, to allow for
> > the possibility of future extension?  I am thinking something like
> > AUTO_SECTION_TARGET with possible values of "node" and "anchor".
> 
> We do not need AUTO_SECTION_TARGET=anchor, by default a section is used
> as target if it is not ambiguous.  I think that we need only a boolean
> customization variable like
>  AUTO_SECTION_NODE

I'm happy with AUTO_SECTION_NODE as the name for such a variable.


> > They are related in that if there is a lone section command "@chapter foo",
> > then @xref{foo} should reference the location of that command in the output,
> > whether or not the command creates a node or not.  Hence there should be
> > some consistency between insert_nodes_for_sectioning_commands being
> > used, and not being used (that consistency could be merely, "foo" exists
> > as a referenceable target, provided there is no target "foo" defined
> > with @node, @anchor or @namedanchor, and there is no other sectioning 
> > command
> > with the name "foo" in the input).
> 
> To me this is what we decided to do, but we could also have decided to have
> different rules for insert_nodes_for_sectioning_commands and shadow
> targets, this consistency is not a necessity.

I don't really understand this point, as there should be rules for what is
a valid Texinfo input file regardless of the options used for texi2any.
For example, whether @xref{foo} is valid or not depends on whether "foo"
is a target.

Reply via email to