Amar Takhar commented on a discussion on cpukit/include/dev/gpio/gpio.h: 
https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1499#note_159797

 > +   *
 > +   * What a pin reads as before rtems_gpio_pin_configure() is called on it,
 > +   * and what it returns to after rtems_gpio_pin_release().
 > +   */
 > +  RTEMS_GPIO_DIRECTION_NONE = 0,
 > +
 > +  /**
 > +   * @brief This enumerator indicates that the pin is an input.
 > +   */
 > +  RTEMS_GPIO_DIRECTION_INPUT,
 > +
 > +  /**
 > +   * @brief This enumerator indicates that the pin is an output.
 > +   */
 > +  RTEMS_GPIO_DIRECTION_OUTPUT
 > +} rtems_gpio_direction;

Yes I have worked on boards that have this too, we should probably have a 
generic name `RTEMS_GPIO_DIRECTION_UNUSED_LOW_POWER` sounds good.  The way it's 
implemented would have to be done in the BSP because it's different for every 
board.  Also, we'd have to decide how to detect if the board supports it or 
not.  Silent fail if it isn't and have another define 
`RTEMS_GPIO_HAS_LOW_POWER`.  That or just keep it undefined if it doesn't exist.

-- 
View it on GitLab: 
https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1499#note_159797
You're receiving this email because of your account on gitlab.rtems.org. 
Unsubscribe from this thread: 
https://gitlab.rtems.org/-/namespace/49/sent_notifications/5-3s1khwd2d89l1yun9ejoqmh3w-1d/unsubscribe
 | Manage all notifications: https://gitlab.rtems.org/-/profile/notifications | 
Help: https://gitlab.rtems.org/help


_______________________________________________
bugs mailing list
[email protected]
http://lists.rtems.org/mailman/listinfo/bugs

Reply via email to