On Wed, 1 Mar 2023 15:00:41 GMT, Adam Sotona <asot...@openjdk.org> wrote:

>> This is root pull request with Classfile API implementation, tests and 
>> benchmarks initial drop into JDK.
>> 
>> Following pull requests consolidating JDK class files parsing, generating, 
>> and transforming 
>> ([JDK-8294957](https://bugs.openjdk.org/browse/JDK-8294957)) will chain to 
>> this one.
>> 
>> Classfile API development is tracked at:
>> https://github.com/openjdk/jdk-sandbox/tree/classfile-api-branch
>> 
>> Development branch of consolidated JDK class files parsing, generating, and 
>> transforming is at:
>> https://github.com/openjdk/jdk-sandbox/tree/classfile-api-dev-branch
>> 
>> Classfile API [JEP](https://bugs.openjdk.org/browse/JDK-8280389) and [online 
>> API 
>> documentation](https://htmlpreview.github.io/?https://raw.githubusercontent.com/openjdk/jdk-sandbox/classfile-api-javadoc-branch/doc/classfile-api/javadoc/java.base/jdk/internal/classfile/package-summary.html)
>>  is also available.
>> 
>> Please take you time to review this non-trivial JDK addition.
>> 
>> Thank you,
>> Adam
>
> Adam Sotona has updated the pull request incrementally with four additional 
> commits since the last revision:
> 
>  - renamed all remaining ConcreteXyzEntry to XyzEntryImpl
>  - abstract implementations of RefEntry, RefsEntry and NamedEntry renamed to 
> AbstractRefEntry, AbstractRefsEntry and AbstractNamedEntry
>  - renamed ConcreteBootstrapMethodEntry to BootstrapMethodEntryImpl
>  - ConcreteEntry renamed to AbstractPoolEntry

src/java.base/share/classes/jdk/internal/classfile/constantpool/ConstantPoolBuilder.java
 line 222:

> 220:      * @param typeEntry the member field or method descriptor
> 221:      */
> 222:     NameAndTypeEntry natEntry(Utf8Entry nameEntry, Utf8Entry typeEntry);

I would be inclined to rename more literally as `nameAndTypeEntry`, which is 
consistent with the naming convention in all other cases in this interface 
AFAICT (edit: almost i also see `bsm`) . (FWIW i keep reading nat as "not a 
type"!)

-------------

PR: https://git.openjdk.org/jdk/pull/10982

Reply via email to