Thought of another one.

Paginate settings, and paginate call.  Why do they have the same
name?  When learning how Cake works, although it's proper OOP to do
so, it's a bit confusing to see:

$this->paginate = array('contain' => 'User');
$this->set('posts', $this->paginate());

I think it would be clearer (from a "name the variable what it is"
type of coding style) to use something like:
$this->paginateOptions = array('contain' => 'User');

Every time I see $this->paginate when skimming through code, I
immediately see the method, completely forgetting it's also a
property.  I "hate" that.  ;)
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"CakePHP" group.
To post to this group, send email to cake-php@googlegroups.com
To unsubscribe from this group, send email to 
cake-php+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/cake-php?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to