Hi, I also have this same problem in version 7.1.1, did anyone find a 
solution to make it work properly?

Also, when I use the line 
cas.webflow.crypto.enabled=false
and log in, the error continues to appear
<java.security.InvalidAlgorithmParameterException: AlgorithmParameterSpec 
not of GCMParameterSpec>
I started it in a completely empty instance of CAS from the Cas Initializr 
page
El martes, 9 de abril de 2024 a las 13:02:59 UTC+2, Meysam Shirazi escribió:

> Hi
> Define 128  key length to use GCMParameterSpec instead of IvParameterSpec:
> cas.webflow.crypto.encryption.key-size:128
>
> On Monday, February 12, 2024 at 4:37:06 PM UTC+3:30 Vaibhav GPT wrote:
>
>> Hi try adding this in cas.properties and see if it helps
>>
>> cas.webflow.crypto.enabled=false
>>
>>
>>
>> On Wednesday, February 7, 2024 at 12:38:36 PM UTC+5:30 Mm Mm wrote:
>>
>> when I run cas in embedded tomcat mode the following error appears when 
>> visiting the login page 
>>
>> ERROR [org.apereo.cas.web.flow.executor.EncryptedTranscoder] - 
>> <java.security.InvalidAlgorithmParameterException: AlgorithmParameterSpec 
>> not of GCMParameterSpec
>>
>> I am using cas7.0.0
>>
>> any suggestions ?
>>
>>

-- 
- Website: https://apereo.github.io/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/fd20e0ee-df99-4c15-bcb1-863db539230dn%40apereo.org.

Reply via email to