Stein M. Hugubakken wrote:

Werner Guttmann wrote:



for some initial thoughts. An addition, if you check out the code, in src/docs you'll find ExolabJavaCoding.pdf.



It's several things I disagree with in this document, like placing variables at the top of the method and comment right-braces that closes a block longer then 10 lines.



Regarding coding-conventions, I propose that we don't "compress" conditional statements, here is an example that's hard to read and inefficient when I'm stepping in the debugger:
if ( _db.isActive() ) _db.rollback();
_db.close();


This code should at least be like this:
 if (_db.isActive())
        _db.rollback();
_db.close();

but I prefer the curly-braces way:
 if (_db.isActive()){
        _db.rollback();
}
_db.close();

Any comments?

Stein

----------------------------------------------------------- If you wish to unsubscribe from this mailing, send mail to
[EMAIL PROTECTED] with a subject of:
unsubscribe castor-dev




Reply via email to