Hi,

I am working on a problem where CME router is configure as
routing-on-a-stick with 4 different VLAN due to performance problem I
want to move layer-3 routing on cisco 3650 switch.

Here is my configuration on CME and L3 switch. Everything is working
fine. External called is able to record voice-mail and phone and able
to access mailbox on CUE.
----------

Please suggest if you see anything  drawback with this configurations.

interface GigabitEthernet0/1
Description ==>L3 connection to switch port Gi0/1
 ip address 172.25.169.1 255.255.255.192
 duplex auto
 speed auto
!

interface Loopback1
 ip address 172.30.23.37 255.255.255.252
!

interface Service-Engine0/0
 ip unnumbered Loopback1
 service-module ip address 172.30.23.38 255.255.255.252
 service-module ip default-gateway 172.30.23.37
!
ip route 172.30.23.38 255.255.255.255 Service-Engine0/0

!
router eigrp 64831
 passive-interface default
 no passive-interface GigabitEthernet0/1
 network 172.25.169.1 0.0.0.0
 network 172.30.23.37 0.0.0.0
 auto-summary
!
telephony-service
 max-ephones 58
 max-dn 150
 ip source-address 172.30.23.37 port 2000

!
dial-peer voice 4701 voip
 destination-pattern 4701
 session protocol sipv2
 session target ipv4:172.30.23.37
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad

-------------------------------------------

on 3560 Switch
----------

ip dhcp excluded-address 172.25.169.65 172.25.169.67
!
ip dhcp pool iphone
   network 172.25.169.64 255.255.255.192
   default-router 172.25.169.65
   option 150 ip 172.30.23.37
!
interface Vlan70
 ip address 172.25.169.65 255.255.255.192
end
!
interface GigabitEthernet0/17
 switchport mode access
 switchport voice vlan 70
 spanning-tree portfast

!

router eigrp 64831
no auto-summary
 network 172.25.169.2 0.0.0.0
 network 172.25.169.65 0.0.0.0
!
--

cmerouter#sh cdp neigh | inc Gig 0/1
Switch           Gig 0/1            176         R S I     WS-C3560G Gig 0/1

!

Thanks & Regards,
Ramcharan Arya
CCIE # 28926
_______________________________________________
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Reply via email to