arsenm added inline comments.

================
Comment at: lib/CodeGen/CGBuiltin.cpp:11313-11315
+  case AMDGPU::BI__builtin_amdgcn_update_dpp: {
+    llvm::SmallVector<llvm::Value *, 6> Args;
+    for (unsigned I = 0; I != 6; ++I)
----------------
b-sumner wrote:
> arsenm wrote:
> > The only difference between this and mov_dpp is the argument count and the 
> > intrinsic ID, so you can combine the cases
> We should really drop mov_dpp.  It will be easier to do so if we keep the 
> cases separate. 
We could also emit the mov_dpp with the new intrinsic, using I think undef for 
the extra operand?


https://reviews.llvm.org/D52320



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to