aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land.
LGTM aside from some minor nits. ================ Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:340 + return false; + if (FDecl->getAccess() == AS_private || FDecl->getAccess() == AS_protected) + return false; ---------------- I'd flip the logic to `!= AS_public` to be more clear that we only care about public members. ================ Comment at: clang-tools-extra/docs/clang-tidy/checks/readability-identifier-naming.rst:833 + + When set to ``1`` functions that have a similar signature to ``main`` won't + enforce checks on the names of their parameters. ---------------- We should document that this defaults to `0` and mention `wmain` as well. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D73098/new/ https://reviews.llvm.org/D73098 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits