ctetreau added a comment.

> I'm concerned though about having getSequentialElementType and 
> getSequentialNumElements apply to different sets of types. That's bound to 
> lead to confusion which causes bugs. Can we have one name for all types that 
> are homogenous sequences of the same element type, and a different name for 
> all types which are *fixed-length* homogenous sequences?

isSequentialType() returns true for VectorType and ArrayType. It should be 
changed to only return true if the vector type is not scalable, and 
getSequentialNumElements() should assert isSequentialType() before attempting 
the casts.

In the future, when my proposed FixedVectorType is added, isSequentialType will 
return true for ArrayType and FixedVectorType only.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75661/new/

https://reviews.llvm.org/D75661



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to