MyDeveloperDay added a comment.

Do we need a set options for when we want to insert/retain/add a newline after 
various constructs? frankly I've been mulling over the concept of adding a

  NewLinesBetweenFunctions: 1

I personally don't like code written like this as I find it hard to read, I'd 
like to be able to mandate a single line between functions

  void foo()
  {
  ...
  }
  void bar()
  {
  ...
  }
  void foobar()
  {
  ...
  }

I prefer when its written as:

  void foo()
  {
  ...
  }
  
  void bar()
  {
  ...
  }
  
  void foobar()
  {
  ...
  }

Maybe we even need a more generalised mechanism that would allow alot of 
flexibility letting people control their own specific style.

  NewLineInsertionStyle: Custom
        AtferNameSpaceOpeningBrace: true
        BeforeNameSpaceClosingBrace: true
        BetweenFunctions: true
        AfterClassOpeningBrace: true
        BeforeClassClosingBrace: true


Repository:
  rZORG LLVM Github Zorg

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D104044/new/

https://reviews.llvm.org/D104044

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to