rjmccall added inline comments.

================
Comment at: lib/AST/Type.cpp:1282
@@ -1277,1 +1281,3 @@
+}
+
 Optional<ArrayRef<QualType>> Type::getObjCSubstitutions(
----------------
ahatanak wrote:
> I added getTypePtr() because the code didn't compile.
Sure.

================
Comment at: lib/CodeGen/CGObjC.cpp:901
@@ -903,1 +900,3 @@
+    uint64_t ivarSize = getContext().toBits(strategy.getIvarSize());
+    llvm::Type *bitcastType = llvm::Type::getIntNTy(getLLVMContext(), 
ivarSize);
     bitcastType = bitcastType->getPointerTo(); // addrspace 0 okay
----------------
ahatanak wrote:
> I've only changed ivarSize. I can change the variable names defined below 
> (RetTy and RetTySize) too if that is necesasry.
Please do.

================
Comment at: lib/Sema/SemaObjCProperty.cpp:1497
@@ -1496,2 +1496,3 @@
   QualType PropertyIvarType = property->getType().getNonReferenceType();
-  bool compat = Context.hasSameType(PropertyIvarType, GetterType);
+  QualType AtomicUnquailifiedType =
+      PropertyIvarType.getAtomicUnqualifiedType(Context);
----------------
You know what, I'm sorry, I didn't look closely enough at the context.  Please 
just rename PropertyIvarType to something like PropertyRValueType.


http://reviews.llvm.org/D20407



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to