davide requested changes to this revision.
davide added a comment.
This revision now requires changes to proceed.

Compact unwind was developed as a goal to replace the DWARF unwind. Some apps 
did not work if the OS was missing DWARF unwind, so we kept both for Intel. The 
binary compatibility issue is non-existent on arm64, but it could be still a 
thing on x86_64. 
If a function cannot be encoded in CU, we need the compiler to emit both (where 
the CU is a magic value that points to the dwarf unwind info for that function).

tl;dr: this is "a nice cleanup", and potentially the bincompat issue might be 
cone, but the cost of breaking programs in the wild is IMHO too high.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D122258/new/

https://reviews.llvm.org/D122258

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to