aaron.ballman added a comment.

This change is missing a test case.



================
Comment at: clang-tidy/readability/RedundantMemberInitCheck.cpp:57
            "initializer for base class %0 is redundant")
-          << Init->getTypeSourceInfo()->getType()
+          << Construct->getType()
           << FixItHint::CreateRemoval(Init->getSourceRange());
----------------
Why is it more correct to use the CXXConstructExpr type information rather than 
the CXXCtorInitializer?


Repository:
  rL LLVM

https://reviews.llvm.org/D26118



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to