xazax.hun accepted this revision.
xazax.hun added a comment.
This revision is now accepted and ready to land.

One nit, otherwise LGTM! Thanks for fixing this!



================
Comment at: lib/StaticAnalyzer/Core/SimpleSValBuilder.cpp:938
       llvm::APSInt Multiplicand(rightI.getBitWidth(), /* isUnsigned */ true);
+      QualType PteeTy = 
resultTy.getTypePtr()->castAs<PointerType>()->getPointeeType();
+      Multiplicand = getContext().getTypeSizeInChars(PteeTy).getQuantity();
----------------
The rest of the code does not abbreviate the Type. I would prefer to name this 
`pointeeType`.


https://reviews.llvm.org/D37478



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to