dcoughlin accepted this revision.
dcoughlin added a comment.
This revision is now accepted and ready to land.

Some nits inline, but looks good to me!



================
Comment at: lib/Analysis/BodyFarm.cpp:388
+  // reference.
+  for (unsigned int i = 2; i < D->getNumParams(); i++) {
+
----------------
Nit: 'i' doesn't match the naming conventions and it is not particularly 
descriptive. Perhaps "ParamIndex"?


================
Comment at: lib/Analysis/BodyFarm.cpp:391
+    const ParmVarDecl *PDecl = D->getParamDecl(i);
+    QualType PTy = PDecl->getType().getNonReferenceType();
+    Expr *ParamExpr = M.makeDeclRefExpr(PDecl);
----------------
Nit: You can move PTy inside the if block so it is not calculated when it is 
not needed.


https://reviews.llvm.org/D39031



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to