george.karpenkov added inline comments.

================
Comment at: include/clang/Analysis/AnalysisDeclContext.h:424
   /// methods during the analysis.
-  BodyFarm *BdyFrm = nullptr;
+  std::unique_ptr<BodyFarm> BdyFrm;
 
----------------
alexfh wrote:
> BdyFrm is somewhat cryptic. Maybe Farm, Bodies or something else that  is not 
> so weirdly abbreviated?
But that's just forced on us by the naming convention, isn't it? I think other 
names are worse though: they don't tell us which class we can look at to figure 
out what is it doing.


https://reviews.llvm.org/D39220



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to