rsmith accepted this revision.
rsmith added inline comments.
This revision is now accepted and ready to land.


================
Comment at: lib/Sema/SemaOverload.cpp:7618
 
-  // Define some constants used to index and iterate over the arithemetic types
-  // provided via the getArithmeticType() method below.
-  // The "promoted arithmetic types" are the arithmetic
+  SmallVector<CanQualType, 24> ArithmeticTypes;
+
----------------
Can we do better than a magic number here? I don't like that getting this wrong 
will lead to a silent performance change. (Can we at least assert `isSmall()` 
below or something?)


https://reviews.llvm.org/D39579



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to