NoQ marked an inline comment as done.
NoQ added inline comments.

================
Comment at: lib/StaticAnalyzer/Core/ExprEngineCXX.cpp:516
+        if (!ProtoType->isNothrow(getContext()))
+          State = State->assume(RetVal.castAs<DefinedOrUnknownSVal>(), true);
+    }
----------------
george.karpenkov wrote:
> This is neither here nor there, but for this and many other cases I think we 
> could be considerably more readable by defining helpers `State->assumeIsTrue` 
> and `State->assumeIsFalse` (or `assumeNonNull`, or whatever is most 
> descriptive)
Dunno, `assume(x, true)` sounds descriptive enough to me, and also feels more 
like a natural spoken language.


https://reviews.llvm.org/D42192



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to