t-tye requested changes to this revision.
t-tye added inline comments.
This revision now requires changes to proceed.


================
Comment at: lib/Basic/Targets/AMDGPU.cpp:362
+    Builder.defineMacro(Twine("__") + Twine(GPUName));
+    Builder.defineMacro(Twine("__") + Twine(GPUName) + Twine("__"));
+  }
----------------
b-sumner wrote:
> At the meeting we discussed defining every alias of the given GPU, rather 
> than only the mcpu name.   Were we going to proceed with that?
Subsequent discussion settled on only defining the canonical names. If it was 
useful to also have the alternative names a header file could be provided that 
defines those names in response to the canonical names being defined.


================
Comment at: lib/Basic/Targets/AMDGPU.cpp:336
+  if (GPU.Kind != GK_NONE) {
+    Builder.defineMacro(Twine("__") + Twine(GPU.CanonicalName));
+    Builder.defineMacro(Twine("__") + Twine(GPU.CanonicalName) + Twine("__"));
----------------
Subsequent discussion decided to drop this macro.


https://reviews.llvm.org/D36802



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to