the 0.0.0.0 denotes the specified address only.
RouterA
     int s0
        ip addr 172.21.1.10  255.255.255.0
    int s1
        ip addr 172.21.2.20  255.255.255.0
    int s2
        ip addr 172.21.3.30  255.255.255.0


Ex. 1
router ospf 1
    network 172.21.1.10  0.0.0.0 area 0
    network 172.21.2.20  0.0.0.0 area 0
    network 172.21.3.30  0.0.0.0 area 0

Ex. 2
router ospf 1
    network 172.21.1.0  0.0.0.255 area 0
    network 172.21.3.0  0.0.0.255 area 0

Ex. 3
router ospf 1
    network 172.21.0.0  0.0.255.255 area 0

Ex. 1 just routes the subnetted network by using interface address. You can then
just "shutdown" specified interface to stop ospf routing for network/interface
instead of "no router ospf 1", which in a crunch, you might forget to cut and
paste into text editor. Otherwise you'd have to show startup-config, and wait
for config to show on screen, and then cut and paste.

Ex. 2 will enable routing entries for entire subnet, which might cause a problem
if you make a mistake of adding an ip address in specified subnet on another
router interface.

Ex. 3 to summarize all 3 subnets

Tom Trygar

Kevin Wigle wrote:

> If you look further to page 201 in the description for the network / area
> command........
>
> 0.0.0.0 is used to specify that the mask uses the interface address
>
> If you look at RouterA it uses an inverse mask
>
> network 10.0.0.0 0.255.255.255 area 0
>
> but look at RouterB, it uses
>
> network 10.64.0.2 0.0.0.0 area 0
>
> now look at the interface configuration, ip address 10.64.0.2 255.255.255.0
>
> in this case the "0.0.0.0" will be interpreted as 0.255.255.255
>
> sort of a shortcut if the router has multiple interfaces.
>
> Kevin Wigle
> CCDA CCNA CBE CBI MCSE
>
> ----- Original Message -----
> From: Field, Brian <[EMAIL PROTECTED]>
> To: <[EMAIL PROTECTED]>
> Sent: Wednesday, 10 May, 2000 21:59
> Subject: OSPF question- network statement
>
> >
> > In the ACRC book (page 200), the author shows the 10.64.0.1/24
> > network being placed into an area 0 with the command:
> >
> > network 10.64.0.1 0.0.0.0 area 0
> >
> > Why is the wild card mask 0.0.0.0 used and not a mask
> > which matches the actual manner in which the network
> > has been subneted?  Is there any difference to the operation
> > of the router, area, OSPF, or area routing if the above was
> > changed to:
> >
> > network 10.64.0.1 0.0.0.255 area 0
> >
> > ?
> >
> > If the above two forms result in identical operation,
> > why is the wild card mask required?
> >
> > Thanks,
> > Brian
> >
> > ___________________________________
> > UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
> > FAQ, list archives, and subscription info: http://www.groupstudy.com
> > Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
> >
>
> ___________________________________
> UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
> FAQ, list archives, and subscription info: http://www.groupstudy.com
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to