There are 2 problems with the route-map.

1. Syntax should be "set ip next-hop serial0"
2. There is no match in the map for 192.168.2.0 so
those packets will get dropped.

Correct config should be:

route-map test permit 10
>  match ip address 10
>  set ip next-hop interface serial0
> 
> route-map test permit 20
>  match ip address 11
   set ip next-hop interface serial1
> 
> access-list 10 permit 192.168.1.0 0.0.0.255 
  access-list 11 permit 192.168.2.0 0.0.0.255

Regards,

Cormac Long CCSI#21600
http://www.cormaclong.com

--- Nurarif Wibawa <[EMAIL PROTECTED]> wrote:
> Hi guys,
> 
> Please see configurations below :
> ISP A owned 192.168.1.0/24 and ISP B owned
> 192.168.2.0/24
> 
>         ISP A            ISP B
>            |                     |
>            |                     |
>         serial0           serial1
>                  ethernet0 -> using secondary
> address
>                   |          |
>                   |          |
> 192.168.1.0/24       192.168.2.0/24
> 
> Customer which has 2 ISP using 2 serial interfaces
> and 1 ethernet interface.
> Lets say, user which configured with network
> 192.168.1.0 should go through serial0 and user which
> configured with network 192.168.2.0 should go
> through serial1
> Please correct the router configuration below :
>
-------------------------------------------------------------------------------------
> interface serial0
>  ip address 192.168.3.1 255.255.255.252
> 
> interface serial1
>  ip address 192.168.4.1 255.255.255.252
> 
> interface ethernet0
>  ip address 192.168.1.1 255.255.255.0
>  ip address 192.168.2.1 255.255.255.0 secondary
>  ip policy route-map test
>  
> route-map test permit 10
>  match ip address 10
>  set interface serial0
> 
> route-map test permit 20
>  set interface serial1
> 
> access-list 10 permit 192.168.1.0 0.0.0.255 
>
--------------------------------------------------------------------------------------
> 
> Did I miss something ? because it won't work.
> 
> 
> Thank you
> 
>         
> 


=====
http://www.cormaclong.com

__________________________________________________
Do You Yahoo!?
Kick off your party with Yahoo! Invites.
http://invites.yahoo.com/

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to