I was trying to do this async callback in my lab. Have tried to get answer
from books and Cisco website for quite some time but with no luck. Seek help
from the group.

By looking at the debug info, seemed the callback client is working OK but
missed something on the callback server side as there was no callback.

Callback server :-
================
c2509rj#sh run
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname c2509rj
!
enable secret 5 $1$FNXZ$OXAMRvJMI90li81Ua.h3b1
!
username c2501 password 0 samepass
chat-script call-c2501 ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT
\c
!
interface Loopback1
 ip address 1.1.1.1 255.255.0.0
 no logging event subif-link-status
!
interface Ethernet0
 no ip address
 no logging event subif-link-status
 shutdown
!
interface Serial0
 no ip address
 no logging event subif-link-status
 shutdown
!
interface Async2
 ip address 10.1.1.7 255.255.255.0
 encapsulation ppp
 no logging event subif-link-status
 async mode interactive
 dialer in-band
 dialer callback-secure
 dialer idle-timeout 200
 dialer wait-for-carrier-time 120
 dialer map ip 10.1.1.8 name c2501 class dial1 102
 dialer hold-queue 60
 dialer-group 1
 ppp callback accept
 ppp authentication chap
!
no ip classless
!
map-class dialer dial1
 dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
line 1
 no exec
 transport input all
line 2
 password samepass
 autoselect during-login
 autoselect ppp
 script callback call-c2501
 login local
 modem InOut
 modem autoconfigure discovery
 transport input all
 stopbits 1
 speed 115200
 flowcontrol hardware
line 3 8
line aux 0
line vty 0 4
 login
!
end


Callback Client
=============
c2501#sh run
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname c2501
!
!
username c2509rj password 0 samepass
chat-script dial-c2509rj "" "AT Z" OK "ATDT \T" TIMEOUT 300 CONNECT \c
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Async1
 ip address 10.1.1.8 255.255.255.0
 encapsulation ppp
 async mode interactive
 dialer in-band
 dialer map ip 10.1.1.7 name c2509rj 101
 dialer-group 1
 ppp callback request
 ppp authentication chap
!
no ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
line aux 0
 password samepass
 script dialer dial-c2509rj
 login local
 modem InOut
 modem autoconfigure discovery
 transport input all
 stopbits 1
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 login
!
end


Debug
========
c2501#ping 10.1.1.7

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.7, timeout is 2 seconds:

Async1: Dialing cause ip (s=10.1.1.8, d=10.1.1.7)
Async1: Attempting to dial 101
CHAT1: Attempting async line dialer script
CHAT1: Dialing using Modem script: dial-c2509rj  & System script: none
CHAT1: process started
CHAT1: Asserting DTR
CHAT1: Chat script dial-c2509rj started
CHAT1: Sending string: AT Z
CHAT1: Expecting string: OK
CHAT1: Completed match for expect: OK
CHAT1: Sending string: ATDT \T
CHAT1: Expecting string: CONNECT.....
Success rate is 0 percent (0/5)
c2501#
CHAT1: Completed match for expect: CONNECT
CHAT1: Sending string: \c
CHAT1: Chat script dial-c2509rj finished, status = Success
%LINK-3-UPDOWN: Interface Async1, changed state to up
As1 PPP: Treating connection as a callout
%LINK-3-UPDOWN: Interface Async2, changed state to up
Async2: Dialer received incoming call from <unknown>
Async2:Callback server starting to c2501 102
Async2: disconnecting call
As1 PPP: Phase is AUTHENTICATING, by both
As1 CHAP: O CHALLENGE id 9 len 26 from "c2501"
As1 CHAP: I CHALLENGE id 9 len 28 from "c2509rj"
As1 CHAP: O RESPONSE id 9 len 26 from "c2501"
As1 CHAP: I SUCCESS id 9 len 4
As1 CHAP: I RESPONSE id 9 len 28 from "c2509rj"
As1 CHAP: O SUCCESS id 9 len 4
Async1: Callback negotiated - waiting for server disconnect
%LINK-5-CHANGED: Interface Async2, changed state to reset
%LINK-5-CHANGED: Interface Async1, changed state to reset
Callback client for c2509rj 101 created
%LINK-3-UPDOWN: Interface Async2, changed state to down
%LINK-3-UPDOWN: Interface Async1, changed state to down
Async2: re-enable timeout
callback triggered by dialer_timers
Async2:beginning callback to c2501 102
Async2: Attempting to dial 102
CHAT2: Attempting async line dialer script
CHAT2: no matching chat script found for 102
Async2: Unable to dial 102.
: Dialing failed, 0 packets unqueued and discarded
: unable to dial callback return call
Freeing callback to c2501 102
Async1: re-enable timeout
Async2: re-enable timeout
No callback received from c2509rj 101
Freeing callback to c2509rj 101

=======================











_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to