OK, your only using one area for the whole OSPF network.  This means that
both routerA and routerC are not ABR (border different areas).  The area
range command only works on ABR's.  This now leaves you with a couple of
choices.  RouterB is the ASBR (redistributes from OSPF into a different
protocol on the same router) and can use the 'summary address' command under
the OSPF process to summarize the area into a /24.    Rather than trying to
get your OSPF routes into IGRP, use the default-netowork command on the IGRP
router to give it a default route out of the IGRP domain without knowing
where it is sending routes.  You will need to enable 'IP classless' on the
IGRP router and you will need a network injected into IGRP that is not one
of the networks it has routes for.   You could do this by adding a static
route to null0 which you probably won't want to do, or you could add a
network to routerB (try a loopback with a /24 so it gets redistributed) and
once it can be seen in the IGRP router route-table, the default-network
command will add a candidate default route to your route-table.

When using the IGRP default-network command, only use a classfull address.
If you use a subnetted address a static route will be injected into your
config that only a reboot will remove!!

HTH


----- Original Message -----
From: John Neiberger <[EMAIL PROTECTED]>
To: Groupstudy <[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>
Sent: Saturday, March 17, 2001 8:38 PM
Subject: Re: VLSM, OSPF, and redistribution into IGRP


> Ok, here are the relevant portions of the configs.
>
> Router A:
>
> ip subnet-zero
> !
> interface Ethernet0
>  ip address 10.1.1.33 255.255.255.224
>  no keepalive
> !
> interface Serial0
>  ip address 10.1.2.2 255.255.255.224
>  no fair-queue
> !
> router ospf 1
>  network 10.1.2.0 0.0.0.31 area 0
>  network 10.1.1.32 0.0.0.31 area 0
> !
> ip classless
>
> Router B:
>
> ip subnet-zero
> !
> interface Serial0
>  ip address 10.1.2.1 255.255.255.224
>  clockrate 500000
> !
> interface Serial1
>  ip address 10.1.3.1 255.255.255.0
> !
> router ospf 1
>  network 10.1.2.0 0.0.0.31 area 0
>  area 0 range 10.1.1.0 255.255.255.0
>  area 0 range 10.1.2.0 255.255.255.0
> !
> router igrp 1
>  redistribute ospf 1 metric 10000 1000 255 1 1500
>  passive-interface Serial0
>  network 10.0.0.0
>  default-metric 10000 1000 255 1 1500
> !
> ip classless
>
> Here is the routing table for Router B:
>
> RouterB#sho ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
> default
>
> Gateway of last resort is not set
>
>      10.0.0.0 is variably subnetted, 3 subnets, 2 masks
> C       10.1.3.0 255.255.255.0 is directly connected, Serial1
> C       10.1.2.0 255.255.255.224 is directly connected, Serial0
> O       10.1.1.32 255.255.255.224 [110/74] via 10.1.2.2, 00:09:01, Serial0
>
> And finally, Router C:
>
> ip subnet-zero
> !
> interface Serial1
>  ip address 10.1.3.2 255.255.255.0
>  clockrate 500000
> !
> router igrp 1
>  network 10.0.0.0
> !
> ip classless
>
> As I understand it, Router B would summarize 10.1.1.32/27 as 10.1.1.0/24
so
> that it can be redistributed into IGRP.  As you can see, 10.1.1.32/27 is
in
> the routing table, yet from debugging I can see that the summarized route
is
> not being added to the IGRP update, and therefore RouterC is never seeing
> the route.  I found a different way to make this work, but I wanted to
> figure it out using the method in the book.  So far, no luck.
>
> Another oddity that I noticed that I need to check into:  on RouterA, I
had
> to add a network statement for the 10.1.1.32/27 network or it wouldn't be
> advertised.  Why is this?  I thought that the OSPF network statement
> specified which interfaces were to participate in the OSPF process, not
the
> actual networks to be advertised (like in BGP.)  It seems to me that the
> 10.1.1.32/27 network would be part of the Router LSA, with or without a
> specific network statement.
>
> Thanks,
> John
>
> >  Need to see the remainder of your configs.  I don't think you are using
> the
> >  correct area range summary but without knowing your addressing scheme,
I
> >  cannot say for sure.
> >
> >
> >  ----- Original Message -----
> >  From: John Neiberger <[EMAIL PROTECTED]>
> >  To: <[EMAIL PROTECTED]>
> >  Sent: Saturday, March 17, 2001 2:59 PM
> >  Subject: VLSM, OSPF, and redistribution into IGRP
> >
> >
> >  > I'm working through a scenario in the new Sybex CCIE study guide and
I
> >  can't
> >  > get it to work, even using their suggested workaround.  Here's the
> >  scenario:
> >  >
> >  > RouterA <--OSPF--> RouterB <--IGRP--> RouterC
> >  >
> >  > RouterA has two different /27 links, one of which is connected to
> RouterB.
> >  > The connecting link is 10.1.2.0/27 and its other link is
10.1.1.32/27.
> >  >
> >  > The link between RouterB and RouterC is a /24, 10.1.3.0.  The purpose
> of
> >  the
> >  > scenario is to demonstrate that the /27 networks will not be
> redistributed
> >  > in IGRP because the masks are different on each side of RouterB.  To
> >  remedy
> >  > this problem, the book suggests summarizing the /27 networks as /24
> which
> >  > would allow them to be redistributed into a classful protocol.
> Following
> >  > the instructions, on RouterB I added:
> >  >
> >  > router ospf 1
> >  >  area 0 range 10.1.1.0 255.255.255.0
> >  >
> >  > Supposedly, this would work but it does not.  Closer to their
example,
> I
> >  > even tried "area 0 range 10.1.1.32 255.255.255.0".  Am I doing it
> >  > incorrectly or is their suggestion wrong?  I worked around this
problem
> by
> >  > creating a summarized static route on RouterB and then redistributing
> >  > static, but I wanted to make it work like in their example.
> >  >
> >  > So, redistribution gurus, what's the story?  I quickly looked through
> >  > Doyle's book and I haven't seen this specific example yet.
> >  >
> >  > Any ideas?
> >  >
> >  > Many thanks,
> >  > John
> >  >
> >  >
> >  >
> >  >
> >  >
> >  > _______________________________________________________
> >  > Send a cool gift with your E-Card
> >  > http://www.bluemountain.com/giftcenter/
> >  >
> >  >
> >  > _________________________________
> >  > FAQ, list archives, and subscription info:
> >  http://www.groupstudy.com/list/cisco.html
> >  > Report misconduct and Nondisclosure violations to
[EMAIL PROTECTED]
> >  >
> >
> >  _________________________________
> >  FAQ, list archives, and subscription info:
> http://www.groupstudy.com/list/cisco.html
> >  Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>
>
>
>
>
> _______________________________________________________
> Send a cool gift with your E-Card
> http://www.bluemountain.com/giftcenter/
>
>
>

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to