This is an example for two different ISPs at a different time of day: (as
you can see, the route map is the key, for your case too)

Current configuration:
!
! Last configuration change at 15:07:03 UTC Thu Jun 21 2001
! NVRAM config last updated at 15:22:39 UTC Thu Jun 21 2001
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
ip name-server 212.59.0.1
ip name-server 212.122.64.13
!
ip dhcp pool my
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   dns-server 212.59.0.1 
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
!
!
!
interface Loopback100
 no ip address
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 no ip route-cache
 no ip mroute-cache
ip policy route-map time-based-access
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
interface TokenRing0/0
 no ip address
 no ip directed-broadcast
 shutdown
 ring-speed 16
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-net3
 no cdp enable
!
interface Dialer1
 description Access to Telekomas
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer string 392222
 dialer-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname XXXXXXX
 ppp chap password 7 XXXXXXXXX
 ppp multilink
!
interface Dialer2
 description Access to 5ci
 ip address negotiated
 no ip directed-broadcast
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer string 688888
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username XXXXXX password 7 XXXXXXXX
 ppp multilink
!
ip nat translation timeout 10
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source list 103 interface Dialer2 overload
ip classless
no ip http server
!
access-list 102 remark ACL for DDR during day-hours
access-list 102 permit ip any any time-range day-hours
access-list 103 remark ACL for DDR during evening-hours
access-list 103 permit ip any any time-range evening-hours
dialer-list 1 protocol ip permit
route-map time-based-access permit 10
 match ip address 102
 set default interface Dialer1
!         
route-map time-based-access permit 20
 match ip address 103
 set default interface Dialer2
!
route-map time-based-access permit 30
 set default interface Null0
!
!
!
line con 0
 exec-timeout 120 0
 transport input none
line aux 0
line vty 0 4
 login
!
time-range day-hours
 periodic weekdays 8:00 to 15:00
!
time-range evening-hours
 periodic weekdays 15:00 to 15:30


Enjoy!
And tell your customer to continue buying Cisco equipment.

Regards,
Dragi



Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=9960&t=9899
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to