Katson,
           Based on what you posted I would recommend looking at the debugs
on R5 as the RIB is built and the IGRP routes are advertised to R4.  If it
never leaves R5 for whatever reason then it won't be seen on R4.

There has been a number of discussions on this issue(ospf and mask
implementation) and ospf doesn't care about mask information in building the
local LS database.  The use of netmask defined under the ospf process is
only a configuration enhancement which provides a simpler way to configure
multiple interfaces as compared to having to type numerous individual
statements that are local to the router.

Where the mask information does matter is when ospf router hellos are
forming adjacencies in which case this is a mechanism used to confirm the
connected routers are on the same network segment.

The most important thing to remember here is that OSPF is a
"link"(interface) state protocol.  All ospf needs to identify is which
interface to implement the protocol so as to discover any other ospf enabled
routers.

Look at you router configs again.  Also look at your LS Database "sho ip
ospf data router" and verify that the local router(R5) does know about the
link that you're expecting to see on R4.  There is no issue here short of
this being one of those special "features" that cisco sometimes add to
various IOS releases...:->

Otherwise this should work without any problems..

HTH

Nigel


----- Original Message -----
From: "[EMAIL PROTECTED] (Katson PN Yeung)"

To: 
Sent: Sunday, December 16, 2001 12:14 AM
Subject: OSPF network wildcard mask affects redistribution (Bootcamp Lab
[7:29321]


> I am doing bootcamp Lab5a and found this funny behaviour.
>
> I have enabled "debug ip igrp protocol" and "debug ip igrp event" at
> R4 to make the igrp updates visualized.
>
>
> With R4 config unchange, I toggle the wildcard mask at the router ospf
>
> section.
>
>
> Test 1: "network 137.20.20.10 0.0.0.0 area 0"
> Test 2: "network 137.20.20.10 0.0.0.255 area 0"
> Test 3: "network 137.20.20.0 0.0.0.255 area 0"
>
>
> At test 2 and 3, R5 will redistribute 137.20.0.0 to igrp, and this
> igrp update from R5 can be seen at R4 debug.
>
>
> However, at test 1, then the wildcard mask becomes 0.0.0.0, the igrp
> update from R5 about 137.20.0.0 is disappear!
>
>
>
> Can someone tell me what is the effect of OSPF network wildcard mask
> in OSPF-IGRP redistribution?
>
>
>
> See the configurations and test results below:
>
>
> Router4
> -----------------------------------------------------
> router igrp 101
>  passive-interface Ethernet0
>  network 172.168.0.0
>
>
> interface Serial0
>  ip address 172.168.200.2 255.255.255.0
>  encapsulation frame-relay
>  ip split-horizon
>  no ip mroute-cache
>  frame-relay map ip 172.168.200.1 214 broadcast
>  frame-relay lmi-type ansi
>
>
>
> Router5
> -----------------------------------------------------
> interface Ethernet0
>  ip address 137.20.20.10 255.255.255.0
>  no ip directed-broadcast
>  ip ospf cost 1
>  ip ospf priority 200
> !
> interface Serial0.2 point-to-point
>  ip address 172.168.200.1 255.255.255.0
>  no ip directed-broadcast
>  frame-relay interface-dlci 131
> !
> router igrp 101
>  redistribute ospf 100 metric 1000 100 255 1 1500
>  passive-interface Serial0.1
>  network 172.168.0.0
> !
> router ospf 100
>  area 10 virtual-link 172.168.30.97
>  area 10 virtual-link 172.168.100.6
>  network 172.168.100.5 0.0.0.0 area 10
> !
>
>
>
>
> Test 1
> ------------------------------------------------------
> When:
>
> R5(config)#router ospf 100
> R5(config-router)#network 137.20.20.10 0.0.0.0 area 0
>
>
> R4#clear ip route *
> R4#
> Dec 15 21:54:11: IGRP: broadcasting request on Serial0
> Dec 15 21:54:11: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 21:54:11:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 21:54:11:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11: IGRP: Update contains 3 interior, 3 system, and 0
> exterior routes.
> Dec 15 21:54:11: IGRP: Total routes in update: 6
> Dec 15 21:54:11: IGRP: edition is now 73
> Dec 15 21:54:11: IGRP: sending update to 255.255.255.255 via Serial0
> (172.168.200.2)
> Dec 15 21:54:11:       subnet 172.168.40.0, metric=1100
> Dec 15 21:54:11: IGRP: Update contains 1 interior, 0 system, and 0
> exterior routes.
> Dec 15 21:54:11: IGRP: Total routes in update: 1
> Dec 15 21:54:11: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 21:54:11:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 21:54:11:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 21:54:11: IGRP: Update contains 3 interior, 3 system, and 0
> exterior routes.
> Dec 15 21:54:11: IGRP: Total routes in update: 6
>
>
> R4#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
> BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
> Gateway of last resort is not set
>
>      172.168.0.0/24 is subnetted, 5 subnets
> I       172.168.30.0 [100/12100] via 172.168.200.1, 00:00:48, Serial0
> C       172.168.40.0 is directly connected, Ethernet0
> I       172.168.60.0 [100/12100] via 172.168.200.1, 00:00:48, Serial0
> I       172.168.100.0 [100/10476] via 172.168.200.1, 00:00:48, Serial0
> C       172.168.200.0 is directly connected, Serial0
> I    192.168.21.0/24 [100/12100] via 172.168.200.1, 00:00:48, Serial0
> I    192.168.17.0/24 [100/12100] via 172.168.200.1, 00:00:48, Serial0
> I    192.168.70.0/24 [100/12100] via 172.168.200.1, 00:00:49, Serial0
>
>
>
> Test 2
> ------------------------------------------------------
> When:
>
> R5(config)#router ospf 100
> R5(config-router)#network 137.20.20.10 0.0.0.255 area 0
>
>
> R4#clear ip route *
> R4#
> Dec 15 22:00:03: IGRP: broadcasting request on Serial0
> Dec 15 22:00:03: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 22:00:03:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 22:00:03:       network 137.20.0.0, metric 8576 (neighbor 1100)
> Dec 15 22:00:03:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03: IGRP: Update contains 3 interior, 4 system, and 0
> exterior routes.
> Dec 15 22:00:03: IGRP: Total routes in update: 7
> Dec 15 22:00:03: IGRP: edition is now 81
> Dec 15 22:00:03: IGRP: sending update to 255.255.255.255 via Serial0
> (172.168.200.2)
> Dec 15 22:00:03:       subnet 172.168.40.0, metric=1100
> Dec 15 22:00:03: IGRP: Update contains 1 interior, 0 system, and 0
> exterior routes.
> Dec 15 22:00:03: IGRP: Total routes in update: 1
> Dec 15 22:00:03: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 22:00:03:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 22:00:03:       network 137.20.0.0, metric 8576 (neighbor 1100)
> Dec 15 22:00:03:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:00:03: IGRP: Update contains 3 interior, 4 system, and 0
> exterior routes.
> Dec 15 22:00:03: IGRP: Total routes in update: 7
>
> R4#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
> BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
> Gateway of last resort is 172.168.200.1 to network 137.20.0.0
>
> I*   137.20.0.0/16 [100/8576] via 172.168.200.1, 00:00:04, Serial0
>      172.168.0.0/24 is subnetted, 5 subnets
> I       172.168.30.0 [100/12100] via 172.168.200.1, 00:00:04, Serial0
> C       172.168.40.0 is directly connected, Ethernet0
> I       172.168.60.0 [100/12100] via 172.168.200.1, 00:00:04, Serial0
> I       172.168.100.0 [100/10476] via 172.168.200.1, 00:00:04, Serial0
> C       172.168.200.0 is directly connected, Serial0
> I    192.168.21.0/24 [100/12100] via 172.168.200.1, 00:00:04, Serial0
> I    192.168.17.0/24 [100/12100] via 172.168.200.1, 00:00:05, Serial0
> I    192.168.70.0/24 [100/12100] via 172.168.200.1, 00:00:05, Serial0
>
>
>
>
>
>
> Test 3
> ------------------------------------------------------
> When:
>
> R5(config)#router ospf 100
> R5(config-router)#network 137.20.20.0 0.0.0.255 area 0
>
>
> R4#clear ip route *
> R4#
> Dec 15 22:02:07: IGRP: broadcasting request on Serial0
> Dec 15 22:02:07: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 22:02:07:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 22:02:07:       network 137.20.0.0, metric 8576 (neighbor 1100)
> Dec 15 22:02:07:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07: IGRP: Update contains 3 interior, 4 system, and 0
> exterior routes.
> Dec 15 22:02:07: IGRP: Total routes in update: 7
> Dec 15 22:02:07: IGRP: edition is now 85
> Dec 15 22:02:07: IGRP: sending update to 255.255.255.255 via Serial0
> (172.168.200.2)
> Dec 15 22:02:07:       subnet 172.168.40.0, metric=1100
> Dec 15 22:02:07: IGRP: Update contains 1 interior, 0 system, and 0
> exterior routes.
> Dec 15 22:02:07: IGRP: Total routes in update: 1
> Dec 15 22:02:07: IGRP: received update from 172.168.200.1 on Serial0
> Dec 15 22:02:07:       subnet 172.168.30.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       subnet 172.168.60.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       subnet 172.168.100.0, metric 10476 (neighbor
> 8476)
> Dec 15 22:02:07:       network 137.20.0.0, metric 8576 (neighbor 1100)
> Dec 15 22:02:07:       network 192.168.21.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       network 192.168.17.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07:       network 192.168.70.0, metric 12100 (neighbor
> 10100)
> Dec 15 22:02:07: IGRP: Update contains 3 interior, 4 system, and 0
> exterior routes.
> Dec 15 22:02:07: IGRP: Total routes in update: 7
>
>
> R4#i
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
> BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
> Gateway of last resort is 172.168.200.1 to network 137.20.0.0
>
> I*   137.20.0.0/16 [100/8576] via 172.168.200.1, 00:01:02, Serial0
>      172.168.0.0/24 is subnetted, 5 subnets
> I       172.168.30.0 [100/12100] via 172.168.200.1, 00:01:02, Serial0
> C       172.168.40.0 is directly connected, Ethernet0
> I       172.168.60.0 [100/12100] via 172.168.200.1, 00:01:02, Serial0
> I       172.168.100.0 [100/10476] via 172.168.200.1, 00:01:02, Serial0
> C       172.168.200.0 is directly connected, Serial0
> I    192.168.21.0/24 [100/12100] via 172.168.200.1, 00:01:02, Serial0
> I    192.168.17.0/24 [100/12100] via 172.168.200.1, 00:01:03, Serial0
> I    192.168.70.0/24 [100/12100] via 172.168.200.1, 00:01:03, Serial0




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=29335&t=29335
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to