I've been studying BGP using several books and papers. One of which is the
Cisco Academy Semester 5 lab companion. So far it's been pretty good but Lab
8-3 drives me nuts.

3 routers.. 3 AS

R1--------R2--------R3
AS100    AS300      AS65000

The idea is to have everyone share routes(did that) and then to filter off
the AS65000 number as the update is sent ot R1(did that)

The kicker was I was *supposed* be able to ping R3 from R1 after this.. no
way.. wasnt going to happen. The only network statements were the loopbacks
for each router.. I was able to ping r3 AFTER I added the network statement
to R2 that id'ed the interface IP between R2 and R1. That was not in the lab..

If someone who has this lab take a look and explain why the ping should or
should not work?

Thanks

MikeS
PS- I really am learning to dislike BGP right now ;)

---lab configs used----


hostname R1
!
!
memory-size iomem 10
ip subnet-zero
!
interface Loopback0
 ip address 201.1.1.1 255.255.255.0
 ip directed-broadcast
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
!
interface Serial0/0
 ip address 192.168.1.5 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
router bgp 100
 no synchronization
 network 201.1.1.0
 neighbor 192.168.1.6 remote-as 300
 neighbor 202.2.2.2 remote-as 300
!
no ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

R1#


hostname R2
!
!
ip subnet-zero
!
!
!
interface Loopback0
 ip address 202.2.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Serial0
 ip address 172.24.1.17 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 clockrate 56000
!
interface Serial3
 ip address 192.168.1.6 255.255.255.252
 no ip directed-broadcast
 clockrate 1000000
!
router bgp 300
 no synchronization
 network 202.2.2.0
 neighbor 172.24.1.18 remote-as 65000
 neighbor 192.168.1.5 remote-as 100
 neighbor 192.168.1.5 remove-private-AS
!
!if I add network 192.168.1.0, I can ping R3 from R1. Without it..no go
no ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

R2#


hostname R3
!
!
no ip subnet-zero
!
!
process-max-time 200
!
interface Loopback0
 ip address 203.3.3.3 255.255.255.0
 ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 172.24.1.18 255.255.255.252
 no ip directed-broadcast
!
router bgp 65000
 no synchronization
 network 203.3.3.0
 neighbor 172.24.1.17 remote-as 300
!
no ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R3#


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=37749&t=37749
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to