At 9:08 PM +0000 7/18/02, cebuano wrote:
>Howard,
>Since 192.168/16 is supposedly Class C, can you tell me why if I
>configure RIPv1 it allows me to configure "network 192.168.0.0" instead
>of giving me an error?

The traditional class C space began with 192/8, of which 192.168/16 
is a part.  I'm puzzled by your comment, since I generally use 
192.168.0.0/24 for /30 serial links when I write scenarios, and never 
have any problem.

There's no formal relationship between RIPv1 and RFC1918 addressing; 
RIPv1 long preceded private addressing.  According to the IETF, RIPv1 
is in "Historic" status, or considered obsolete.

>I've tested it and of course it does not generate
>or accept any updates until you change it something like 192.168.10.0.

I know this runs in some of the Gett scenarios. From S0010:

[EMAIL PROTECTED]
!
!  Establishes initial RIP-only routing on R1.
!
hostname r1
!
interface Loopback0
ip address 192.168.255.1 255.255.255.252
!
interface Loopback1
  ip address 172.16.0.1 255.255.0.0
!
interface Ethernet0/0
  description to Cat 5K 3/1
  ip address 192.168.4.1 255.255.255.0
  half-duplex
!
interface Serial1/0
  no ip address
  encapsulation frame-relay
  no frame-relay inverse-arp
  frame-relay lmi-type ansi
!
interface Serial1/0.2 point-to-point
  description FR hub to R2; rev should be 211
ip address 192.0.2.1 255.255.255.252
  frame-relay interface-dlci 112  
!
interface Serial1/0.3 point-to-point
  description FR hub to R3; rev should be 311
  ip address 192.0.2.5 255.255.255.252
  frame-relay interface-dlci 113  
!
interface Serial1/1
  description serial to R3
  bandwidth 56
  ip address 192.168.0.1 255.255.255.252
!
router rip
  network 172.16.0.0
  network 192.0.2.0
  network 192.168.0.0
  network 192.168.2.0
  network 192.168.4.0
  network 192.168.255.0
ip classless


>Although it reports when you do a "sh ip prot" that it is routing for
>networks 192.168.0.0 and 192.168.10.0. Is this a Cisco IOS "feature"?
>I guess the same thing holds true with my question on the 172.16/12
>Private IP. Thanks in advance for your input.
>
>Elmer
>
>-----Original Message-----
>From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] On Behalf Of
>Howard C. Berkowitz
>Sent: Thursday, July 18, 2002 9:11 AM
>To: [EMAIL PROTECTED]
>Subject: Re: private addressing [7:49083]
>
>>Can anyone tell me.....
>>
>>172.16.0.0 - 172.31.0.0 is used for class B private addressing..
>>
>>That means that it can use 16 class B network address
>>
>>Now, let say I wan to use 172.35.0.0 block, so is this consider a
>private
>>address or a public address ?
>
>Public.
>
>The private blocks are
>
>10/8
>172.16/12
>192.168/16
>
>Again, the sooner you stop thinking in classful terms, the easier
>real-world addressing becomes.




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=49194&t=49083
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to