Elmer,

The way I read your config. You have enabled a single interface with
EIGRP routing, interface loopback17 of network 192.168.199.0/24.

You are redistributing all of EIGRP into BGP which only includes this
one network.

You are aggregating 192.168.192.0 255.255.248.0. The aggregate address
needs a minimum of one network in the aggregate address range to
advertise the supernet and more specific underlying routes.

The BGP table is exactly right as far as I can tell. The only networks
that should appear are the networks redistributed from EIGRP,
192.169.199.0/24, and the aggregate, 192.168.192.0/21, which is using
the previous /24 network for its very existence.

You must enter EACH of the loopbacks under the BGP process using
'network 192.168.192.0 mask 255.255.255.0', 'network 192.168.193.0 mask
255.255.255.0'.....

The mask statement is not necessary in this case, I just always use it
for consistency. It is a personal preference. The mask statement is only
necessary for networks outside their classful boundary.

The other alternative is to include all of the loopbacks under the EIGRP
process and have them redistributed into BGP which you already have
setup, but currently you are only redistributing a single /24. If you
want them all to appear, you need to either enter them under the BGP
process with a network statement or redistribute them from EIGRP.

The route-map you have included in the configs looks like you are
planning on only advertising a subset of the more specific /24 routes.
You should look at the suppress-map option under the aggregate address
command as well as distribute list under the interface or neighbor
statement.

All three of these would accomplish the same result.

-----Original Message-----
From: cebuano [mailto:[EMAIL PROTECTED]] 
Sent: Sunday, September 29, 2002 11:34 PM
To: [EMAIL PROTECTED]
Subject: BGP Aggregation in IOS 12.2 [7:54528]


Hi all.
Has 12.2 changed in that when you do an "aggregate-address" the
configured
router only shows the aggregate route and not include the more-specific
( or
aggregatED ) routes? Here's what I got...
This config is "supposed" to allow me to advertise both the aggregate
and
more-specific routes. But if this has changed then i'll have to think of
another solution...
Thanks.
Elmer

Stowe-2504#s
!
interface Loopback10
 ip address 192.168.192.1 255.255.255.0
!
interface Loopback11
 ip address 192.168.193.1 255.255.255.0
!
interface Loopback12
 ip address 192.168.194.1 255.255.255.0
!
interface Loopback13
 ip address 192.168.195.1 255.255.255.0
!
interface Loopback14
 ip address 192.168.196.1 255.255.255.0
!
interface Loopback15
 ip address 192.168.197.1 255.255.255.0
!
interface Loopback16
 ip address 192.168.198.1 255.255.255.0
!
interface Loopback17
 ip address 192.168.199.1 255.255.255.0
!
interface Serial0
 bandwidth 64
 ip address 192.168.1.254 255.255.255.252
!
router eigrp 100
 network 192.168.199.0
!
router bgp 100
 aggregate-address 192.168.192.0 255.255.248.0
 redistribute eigrp 100
 neighbor 192.168.1.253 remote-as 200
 neighbor 192.168.1.253 send-community
 neighbor 192.168.1.253 route-map community out
!
access-list 101 permit ip host 192.168.192.0 host 255.255.248.0
route-map community permit 10
 match ip address 101
 set community none
!
route-map community permit 20
 set community no-export
!

Stowe-2504#sh ip bgp
BGP table version is 9, local router ID is 192.168.199.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.192.0/21 0.0.0.0                            32768 i
*> 192.168.199.0    0.0.0.0                  0         32768 ?




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=54533&t=54528
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to