Duncan Wallace wrote:
> 
> Has anyone had any experience in implementing Windows load
> balancing a
> server cluster ? I have always used hardware based load
> balancers so I
> am somewhat new to the MS flavor. I have a 2621 router and I am
> wondering if it is capable of the following. 

The text that you copied and pasted says what you'll have to do, which is
create a static ARP that points to a multicast address. Cisco does support
this, by the way. See here:

charlotte(config)#arp ?
  A.B.C.D  IP address of ARP entry

charlotte(config)#arp 10.10.0.3 ?
  H.H.H  48-bit hardware address of ARP entry

charlotte(config)#arp 10.10.0.3 0101.0101.0101 ?
  arpa  ARP type ARPA
  sap   ARP type SAP (HP's ARP type)
  smds  ARP type SMDS
  snap  ARP type SNAP (FDDI and TokenRing)

charlotte(config)#arp 10.10.0.3 0101.0101.0101 arpa
charlotte(config)#end
charlotte#
%SYS-5-CONFIG_I: Configured from console by console
charlotte#show run
Building configuration...

Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname charlotte
!
interface Ethernet0
 ip address 10.10.0.2 255.255.255.0
!

interface Serial0
 ip address 192.168.40.2 255.255.255.0
 encapsulation frame-relay
!
arp 10.10.0.3 0101.0101.0101 ARPA
!
line con 0
line aux 0
 transport input all
line vty 0 4
 password cisco
 login
!
end
 
It does seem like a strange solution though, and strange solutions often
mean you'll encounter bugs or other problems, so do keep us posted on how it
goes. Thanks.

_______________________________

Priscilla Oppenheimer
www.troubleshootingnetworks.com
www.priscilla.com


> This is just some
> preliminary information gathering, so I thought I would throw
> it out to
> the group while I do my own research.
> What Windows 2000 Advanced Server says:
> If Network Load Balancing clients are accessing a cluster
> through a
> router when the cluster has been configured to operate in
> multicast
> mode, be sure that the router meets the following requirements:
> *     Accepts an ARP
>  P>  reply that has one MAC address
>  C_address>  in the payload of the ARP structure but appears to
> arrive
> from a station with another MAC address, as judged by the
> Ethernet
> header 
> *     In multicast mode, accepts an ARP reply that has a multicast
> MAC
> address in the payload of the ARP structure 
> This allows the router to map the cluster's
>  r's_primary_IP_address>  primary IP address and other
>  ltihomed_computer> multihomed addresses to the corresponding MAC
> address. If your router does not meet these requirements, you
> can also
> create a static ARP entry in the router. Cisco routers require
> a static
> ARP entry because they do not support the resolution of unicast
> IP
> addresses to multicast MAC addresses
>  lticast_MAC_address> .
>  
>  
> Thanks in advance,
>  
> Duncan Wallace
> [EMAIL PROTECTED]
> 
> 




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=56328&t=56244
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to