> This is to simplify `TrayIconScalingTest.java`. > > 1. Rename `createAndShowGUI` to `createAndShowTrayIcon` which is more > specific. > 2. Move creating tray icon to the top. > 3. Streamline PassFailJFrame with the chained calls, including > `awaitAndCheck`. > 4. Ensure tray is not null before removing the icon. > 5. Pass AWTException as the cause in the wrapped exception. > > Previously, before the builder pattern was introduced, > `PassFailJFrame.positionTestWindow` had had to be called to show the > instructions UI. It's not required any more. Additionally, it has the effect > of moving the instruction frame to the left, which doesn't look good and > sometimes results in positioning the instructions outside of the screen > bounds if the screen resolution is low. > > With the builder pattern, the call to the `build` method shows all the > registered windows on the screen, including the instruction frame. Since > there's no secondary UI, the instructions remain in the centre of the screen.
Alexey Ivanov has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 18 commits: - Merge master - Pass AWTException as the cause in the wrapped exception - Re-arrange the code in TrayIconScalingTest.java Rename createAndShowGUI to createAndShowTrayIcon which is more specific. Move creating tray icon to the top. Streamline PassFailJFrame with the chained calls. Ensure tray is not null before removing the icon. - Minor updates to createUI in ComboPopupBug - Use testUI in ComboPopupBug - Use testUI in DefaultCloseOperation and reduce the number of columns - Use testUI in LightweightCliprect - Remove unused EventQueue import - Use testUI in DefaultSizeTest - Use testUI in FrameRepackTest - ... and 8 more: https://git.openjdk.org/jdk/compare/3b9255eb...7e10304a ------------- Changes: https://git.openjdk.org/jdk/pull/18224/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=18224&range=02 Stats: 27 lines in 1 file changed: 10 ins; 11 del; 6 mod Patch: https://git.openjdk.org/jdk/pull/18224.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/18224/head:pull/18224 PR: https://git.openjdk.org/jdk/pull/18224
