[ 
https://issues.apache.org/jira/browse/CASSANDRA-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12881039#action_12881039
 ] 

Eric Evans commented on CASSANDRA-1204:
---------------------------------------

{quote}
I'm looking over your comments, and a bit confused (or
maybe I just don't agree) with the create keyspace syntax you are
suggesting. It seems that you are suggesting the following:

        create keyspace <keyspace>[placement_strategy=value ]
        create keyspace <keyspace>[placement_strategy=value
[replication_factor = value ] ]

        eg:
          create keyspace foo[placement_strategy=RackUnawareStrategy]
          create keyspace foo[placement_strategy=RackUnawareStrategy
[replication_factor = 3 ]]
{quote}

No, I was suggesting something like...

{noformat}
create keyspace Foo with placement = RackUnawareStrategy and replication_factor 
= 3
create column family Bar with comparator = BytesType and rowscached = 10000
{noformat}

{quote}
But this looks unlike the syntax for the gets and sets and looks
somewhat messier than below this:

          create keyspace foo[RackUnawareStrategy]
          create keyspace foo[RackUnawareStrategy][3]
{quote}

Right. This syntax is similar to how lists are subscripted in some languages, 
which is a pretty good analogy for the data access bits (get and set), but 
doesn't make any sense here IMO.

{quote}
So, am I reading you right, if so, how do you feel about the above
modifications to your corrections?
{quote}

> CliClient Support for add, drop, and rename should be added for keyspace and 
> column family
> ------------------------------------------------------------------------------------------
>
>                 Key: CASSANDRA-1204
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-1204
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Tools
>    Affects Versions: 0.7
>            Reporter: Mason Bryant
>            Priority: Minor
>             Fix For: 0.7
>
>         Attachments: cli_new_methods2.diff
>
>
> Should add support for the add, drop, and rename operations to keyspace and 
> column family in the CliClient.
> Eg:
> add keyspace <keyspace>                                      Add a new 
> keyspace.
> add column family <cf>[comparator]                      Add a new column 
> family.
> drop keyspace <keyspace>                                      Delete a 
> keyspace.
> drop column family <cf>                                  Delete a column 
> family.
> rename keyspace <keyspace>=<keyspace_new_name>                Rename a 
> keyspace.
> rename column family <name>=<new_name>                   Rename a column 
> family.
> Note: I have patch built for this, but drop keyspace corrupts the schema and 
> prevents the node from restarting due to a bug elsewhere (see: CASSANDRA-1203)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to